代码之家  ›  专栏  ›  技术社区  ›  xian

对于描述对象位置和大小的矩形,什么是好的变量名?

  •  2
  • xian  · 技术社区  · 15 年前

    标题是相当简单的,但我要重申一下:对于描述对象位置和大小的矩形,什么是好的变量名?

    编辑 -该对象是一个类似于乒乓球的游戏的球拍,并且已经有一个名为“bounds”的矩形来限制球拍可以移动到的位置。

    最后,我对桨的位置和大小进行了“限制”,并将“可移动区域”限制在可以移动桨的位置。

    9 回复  |  直到 15 年前
        1
  •  5
  •   paxdiablo    15 年前

    如果是划桨,那为什么不划桨呢?这不是火箭科学,它描述了物体及其属性,应该足以将其与其他物体区分开来,除了其他的桨(然后您可以使用paddel1bound或userpadderbound进一步区分)。

        2
  •  2
  •   Demi    15 年前

    考虑到你的问题,为什么不划桨?

        3
  •  1
  •   Alex Martelli    15 年前

    BoundingBox 可能是好的。

        4
  •  1
  •   Arnold Spence    15 年前

    边界框或边界矩形怎么样?

        5
  •  0
  •   BJ Homer    15 年前

    苹果的Cocoa框架使用 frame bounds (含义稍有不同)这类变量。我一直觉得它们很好。如果你只需要一个,我投赞成票 框架 .

        6
  •  0
  •   BobbyShaftoe    15 年前

    如果变量是foo类型,我会选择

    足底角

    或者类似的东西。它还取决于语言和惯例是什么,也许还取决于上下文。

        7
  •  0
  •   dkretz    15 年前

    我喜欢短的。Xybox怎么样?

        8
  •  0
  •   Pi_E    15 年前

    周边怎么样?

        9
  •  0
  •   Santhosh Kumar Tekuri    15 年前

    这个怎么样?

    rectangle nextbounds;//可以将挡板移动到的边界

    矩形边界;//当前边界